是否可以在 macOS High Sierra 版本 10.13.6 上安装 Node.js?这是我的 2014 年中期 Macbook Pro 可以支持的最新版本

分享于2022年12月29日 angular dyld homebrew macos-high-sierra node.js 问答
【问题标题】:Is it possible to install Node.js on macOS High Sierra Version 10.13.6? This is the latest version my mid 2014 Macbook Pro can support是否可以在 macOS High Sierra 版本 10.13.6 上安装 Node.js?这是我的 2014 年中期 Macbook Pro 可以支持的最新版本
【发布时间】:2022-12-22 01:08:35
【问题描述】:

我的 2014 年中期 Macbook Pro 无法更新到 High Sierra 10.13.6。我在谷歌上搜索了几个小时,试图找到一种方法来安装和使用任何版本的 node.js,但尝试了很多东西都没有成功。有没有办法让 Node.js 在我的设备上运行?我的最终目标是使用 Angular

我使用 brew 在终端中安装节点:

$ brew 安装节点

除了其他内容,我还收到了这个警告: 警告:您使用的是 macOS 10.13。 我们(和 Apple)不为这个旧版本提供支持。

安装后,我尝试了以下操作:

$节点

我得到这个回应: dyld:惰性符号绑定失败:找不到符号:____chkstk_darwin 引用自:/usr/local/bin/node(为 Mac OS X 10.15 构建) 预计在:/usr/lib/libSystem.B.dylib

dyld:找不到符号:____chkstk_darwin 引用自:/usr/local/bin/node(为 Mac OS X 10.15 构建) 预计在:/usr/lib/libSystem.B.dylib

中止陷阱:6

  • 你可以在虚拟机中运行 linux。最好的 VM 软件要花钱,但 VirtualBox 是免费的。
  • @DaveS 非常感谢您花时间阅读和评论 Dave,我会调查此事。

【解决方案1】:

我有同样的问题...

我相信 high sierra 支持的最后一个节点 js 版本是 v17.9.1

https://nodejs.org/download/release/v17.9.1/

【讨论】:

  • 非常感谢阅读和评论加布里埃尔,我很感激!我会看看我是否能弄清楚如何安装它